summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-08-31 19:59:51 +0300
committerAndrei Karas <akaras@inbox.ru>2015-09-01 00:19:20 +0300
commit854c72570f49f7ed57f35fce72bc91ebdc08d2ac (patch)
tree577c1b4ce129c52cabbb8665bf1b562a2e3d4f6c /src/Makefile.am
parent366de9963d24841483e6ed8ff4a88f775a1c2fcf (diff)
downloadplus-854c72570f49f7ed57f35fce72bc91ebdc08d2ac.tar.gz
plus-854c72570f49f7ed57f35fce72bc91ebdc08d2ac.tar.bz2
plus-854c72570f49f7ed57f35fce72bc91ebdc08d2ac.tar.xz
plus-854c72570f49f7ed57f35fce72bc91ebdc08d2ac.zip
Add ability to log received packet names to log file.
Also add arrays with id to package info mapping for inbound packets.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 144d4118b..881a75825 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1167,6 +1167,7 @@ manaplus_SOURCES += main.cpp \
net/pethandler.h \
net/playerhandler.h \
net/questhandler.h \
+ net/recvpacketdefine.h \
net/registrationoptions.h \
net/serverfeatures.h \
net/serverinfo.h \
@@ -1178,6 +1179,7 @@ manaplus_SOURCES += main.cpp \
net/worldinfo.h \
net/packetcounters.cpp \
net/packetcounters.h \
+ net/packetinfo.h \
net/packetlimiter.cpp \
net/packetlimiter.h \
net/protocoldefine.h \
@@ -1325,6 +1327,7 @@ manaplus_SOURCES += \
net/tmwa/questhandler.h \
net/tmwa/questrecv.cpp \
net/tmwa/questrecv.h \
+ net/tmwa/recvpackets.h \
net/tmwa/serverfeatures.cpp \
net/tmwa/serverfeatures.h \
net/tmwa/skillhandler.cpp \
@@ -1552,6 +1555,7 @@ manaplus_SOURCES += gui/windows/bankwindow.cpp \
net/eathena/questhandler.h \
net/eathena/questrecv.cpp \
net/eathena/questrecv.h \
+ net/eathena/recvpackets.h \
net/eathena/roulettehandler.cpp \
net/eathena/roulettehandler.h \
net/eathena/rouletterecv.cpp \