summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-02-28 21:12:15 +0300
committerAndrei Karas <akaras@inbox.ru>2015-02-28 21:12:15 +0300
commitb96242e1d5a6af71e6f884596f77268743945c63 (patch)
tree1fc425037771265a1134956641c466095b7349a1 /src/Makefile.am
parent0cc662938674c22bb5a3d1e1521fe90eb28121e4 (diff)
downloadplus-b96242e1d5a6af71e6f884596f77268743945c63.tar.gz
plus-b96242e1d5a6af71e6f884596f77268743945c63.tar.bz2
plus-b96242e1d5a6af71e6f884596f77268743945c63.tar.xz
plus-b96242e1d5a6af71e6f884596f77268743945c63.zip
Build homunculushandler only if eathena enabled.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9ffcfc8f8..efc993a16 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -659,7 +659,6 @@ manaplus_SOURCES += gui/widgets/avatarlistbox.cpp \
net/gamehandler.h \
net/generalhandler.h \
net/guildhandler.h \
- net/homunculushandler.h \
net/inventoryhandler.h \
net/ipc.cpp \
net/ipc.h \
@@ -1264,8 +1263,6 @@ manaplus_SOURCES += \
net/tmwa/generalhandler.h \
net/tmwa/guildhandler.cpp \
net/tmwa/guildhandler.h \
- net/tmwa/homunculushandler.cpp \
- net/tmwa/homunculushandler.h \
net/tmwa/inventoryhandler.cpp \
net/tmwa/inventoryhandler.h \
net/tmwa/itemhandler.cpp \
@@ -1326,7 +1323,9 @@ manaplus_SOURCES += net/tmwa/auctionhandler.cpp \
net/tmwa/familyhandler.cpp \
net/tmwa/familyhandler.h \
net/tmwa/friendshandler.cpp \
- net/tmwa/friendshandler.h
+ net/tmwa/friendshandler.h \
+ net/tmwa/homunculushandler.cpp \
+ net/tmwa/homunculushandler.h
endif
manaplus_CXXFLAGS += -DEATHENA_SUPPORT
@@ -1357,6 +1356,7 @@ manaplus_SOURCES += gui/windows/bankwindow.cpp \
net/elementalhandler.h \
net/familyhandler.h \
net/friendshandler.h \
+ net/homunculushandler.h \
net/eathena/adminhandler.cpp \
net/eathena/adminhandler.h \
net/eathena/auctionhandler.cpp \