summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-02-27 00:45:20 +0300
committerAndrei Karas <akaras@inbox.ru>2015-02-27 01:51:18 +0300
commite13a1fc1d45c009badc10b4ec4a72bbbcf6fe592 (patch)
tree1d6fe1bcab60fb7a7ec2f6911d069394db3b6126 /src/Makefile.am
parentccd272519ec38b15fa5ec24fe4c6daa6eb45e3da (diff)
downloadplus-e13a1fc1d45c009badc10b4ec4a72bbbcf6fe592.tar.gz
plus-e13a1fc1d45c009badc10b4ec4a72bbbcf6fe592.tar.bz2
plus-e13a1fc1d45c009badc10b4ec4a72bbbcf6fe592.tar.xz
plus-e13a1fc1d45c009badc10b4ec4a72bbbcf6fe592.zip
Build cashshophandler only if eathena enabled.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 289aa0116..47f49f8c0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -645,7 +645,6 @@ manaplus_SOURCES += gui/widgets/avatarlistbox.cpp \
gui/windows/worldselectdialog.cpp \
gui/windows/worldselectdialog.h \
net/adminhandler.h \
- net/cashshophandler.h \
net/beinghandler.h \
net/buysellhandler.h \
net/character.h \
@@ -1254,8 +1253,6 @@ manaplus_SOURCES += \
gui/windows/shopselldialog.h \
net/tmwa/adminhandler.cpp \
net/tmwa/adminhandler.h \
- net/tmwa/cashshophandler.cpp \
- net/tmwa/cashshophandler.h \
net/tmwa/beinghandler.cpp \
net/tmwa/beinghandler.h \
net/tmwa/buysellhandler.cpp \
@@ -1330,7 +1327,9 @@ manaplus_SOURCES += net/tmwa/auctionhandler.cpp \
net/tmwa/bankhandler.cpp \
net/tmwa/bankhandler.h \
net/tmwa/buyingstorehandler.cpp \
- net/tmwa/buyingstorehandler.h
+ net/tmwa/buyingstorehandler.h \
+ net/tmwa/cashshophandler.cpp \
+ net/tmwa/cashshophandler.h
endif
manaplus_CXXFLAGS += -DEATHENA_SUPPORT
@@ -1357,6 +1356,7 @@ manaplus_SOURCES += gui/windows/bankwindow.cpp \
net/auctionhandler.h \
net/bankhandler.h \
net/buyingstorehandler.h \
+ net/cashshophandler.h \
net/eathena/adminhandler.cpp \
net/eathena/adminhandler.h \
net/eathena/auctionhandler.cpp \