summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-01-02 22:54:36 +0300
committerAndrei Karas <akaras@inbox.ru>2016-01-03 00:46:28 +0300
commit519c2796e52ea933f6de5a490aee1f1ab826ea5e (patch)
tree01205558a568663d1c1ff67fda39ee84ce4051ec /src/Makefile.am
parent2d2bbb2fe5a0dc55cbf5b9616a78500704b6ea65 (diff)
downloadplus-519c2796e52ea933f6de5a490aee1f1ab826ea5e.tar.gz
plus-519c2796e52ea933f6de5a490aee1f1ab826ea5e.tar.bz2
plus-519c2796e52ea933f6de5a490aee1f1ab826ea5e.tar.xz
plus-519c2796e52ea933f6de5a490aee1f1ab826ea5e.zip
Add support for custom NLS (without gettext).
Add configure flag --enable-customnls Add empty directory in data/translations/manaplus for suctom translations (po files from /po directory)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 183e7730c..cf4280eca 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,6 +18,11 @@ dyecmd_CXXFLAGS += -DENABLE_PORTABLE
manaplus_CXXFLAGS += -DENABLE_PORTABLE
endif
+if ENABLE_CUSTOMNLS
+dyecmd_CXXFLAGS += -DENABLE_CUSTOMNLS
+manaplus_CXXFLAGS += -DENABLE_CUSTOMNLS
+endif
+
if ENABLE_CHECKPLUGIN
dyecmd_CXXFLAGS += -DENABLE_CHECKPLUGIN -fplugin=../build/checkplugin.so -fplugin-arg-checkplugin-command=detectnullpointers
manaplus_CXXFLAGS += -DENABLE_CHECKPLUGIN -fplugin=../build/checkplugin.so -fplugin-arg-checkplugin-command=detectnullpointers