summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-01-30 15:56:42 +0300
committerAndrei Karas <akaras@inbox.ru>2017-01-30 15:56:42 +0300
commit1e42f9a4691b074eac5b47536f9f828809fe16ca (patch)
treeef98365fa5a44232ba56528cb7a62d33925be8c4 /src/Makefile.am
parent4d3cbb385fcfb79bd559c745ca528beef7f41344 (diff)
downloadplus-1e42f9a4691b074eac5b47536f9f828809fe16ca.tar.gz
plus-1e42f9a4691b074eac5b47536f9f828809fe16ca.tar.bz2
plus-1e42f9a4691b074eac5b47536f9f828809fe16ca.tar.xz
plus-1e42f9a4691b074eac5b47536f9f828809fe16ca.zip
Add configure flag for prevent bulding main game code.
New configure flag:--with-manaplusgame / --without-manaplusgame By default it allow build main game code.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 82520dc34..377730fcf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,10 +1,18 @@
AUTOMAKE_OPTIONS = subdir-objects
+if ENABLE_MANAPLUSGAME
if ENABLE_DYECMD
bin_PROGRAMS = manaplus dyecmd
else
bin_PROGRAMS = manaplus
endif
+else
+if ENABLE_DYECMD
+bin_PROGRAMS = dyecmd
+else
+bin_PROGRAMS =
+endif
+endif
dyecmd_CXXFLAGS = -DPKG_DATADIR=\""$(pkgdatadir)/"\" \
-DLOCALEDIR=\""$(localedir)"\" \
@@ -810,8 +818,9 @@ SRC += utils/xml/libxml.cpp \
endif
dyecmd_SOURCES += ${SRC}
-manaplus_SOURCES += ${SRC}
+if ENABLE_MANAPLUSGAME
+manaplus_SOURCES += ${SRC}
manaplus_SOURCES += main.cpp \
main.h \
avatar.cpp \
@@ -1844,6 +1853,7 @@ manaplus_SOURCES += gui/windows/bankwindow.cpp \
manaplus_SOURCES += \
mumblemanager.cpp \
mumblemanager.h
+endif
dyecmd_SOURCES += dyetool/gui/viewport.cpp \
dyetool/gui/viewport.h \