summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2012-10-25 01:13:56 +0300
committerAndrei Karas <akaras@inbox.ru>2012-10-25 01:18:02 +0300
commit1e4aa6a5e7476bea736b89fe5d7094b6a68705e5 (patch)
treee1f4bda6bcdf5497ae3e7a6b96afc1af563ee7f7 /src/CMakeLists.txt
parentefcee136d7ab46a73286f1ac016d6e3b6a3faed4 (diff)
downloadplus-1e4aa6a5e7476bea736b89fe5d7094b6a68705e5.tar.gz
plus-1e4aa6a5e7476bea736b89fe5d7094b6a68705e5.tar.bz2
plus-1e4aa6a5e7476bea736b89fe5d7094b6a68705e5.tar.xz
plus-1e4aa6a5e7476bea736b89fe5d7094b6a68705e5.zip
Add support for different hover/pickup cursors for monsters, npc, items, etc.
In monsters.xml new monster attribute: hoverCursor - default value "attack". In npcs.xml new npc attribute: hoverCursor - default value "talk". In items.xml new item attribute: pickupCursor - default value "pickup". Warps using "up" cursor for now.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8ea242ee9..96ac9e95d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -414,6 +414,8 @@ SET(SRCS
resources/chardb.h
resources/colordb.cpp
resources/colordb.h
+ resources/cursor.cpp
+ resources/cursor.h
resources/dye.cpp
resources/dye.h
resources/emotedb.cpp