summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2013-04-20 23:00:42 +0300
committerAndrei Karas <akaras@inbox.ru>2013-04-20 23:05:09 +0300
commit52f78717dae3cb02eb1539841dd2a6bd351f74c1 (patch)
tree78b6bb12fcbb5e1624a76531ef43a25d263b3c79 /src/CMakeLists.txt
parente50c6b9fbcd7713b990012f17665efeb2a284dd2 (diff)
downloadplus-52f78717dae3cb02eb1539841dd2a6bd351f74c1.tar.gz
plus-52f78717dae3cb02eb1539841dd2a6bd351f74c1.tar.bz2
plus-52f78717dae3cb02eb1539841dd2a6bd351f74c1.tar.xz
plus-52f78717dae3cb02eb1539841dd2a6bd351f74c1.zip
add support for GIMP palettes for dye colors.
Palette file must be named palette.gpl and contain colors with correct names. To use it in dye string can be used character @. Example: <color id="2" name="black" value="@Untitled7,Untitled8,Untitled6"/> in all dye string it not tested.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7aaeee334..4aa8104e1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -427,6 +427,7 @@ SET(SRCS
resources/cursor.h
resources/dye.cpp
resources/dye.h
+ resources/dyecolor.h
resources/emotedb.cpp
resources/emotedb.h
resources/fboinfo.h
@@ -452,6 +453,8 @@ SET(SRCS
resources/npcdb.h
resources/openglimagehelper.cpp
resources/openglimagehelper.h
+ resources/palettedb.cpp
+ resources/palettedb.h
resources/petdb.cpp
resources/petdb.h
resources/resource.cpp