summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-02-28 22:49:10 +0300
committerAndrei Karas <akaras@inbox.ru>2017-02-28 22:49:10 +0300
commitdb31c2f832dd4067e4670dd469fe3b696188576b (patch)
tree7ed857adddd833cfd5087ee6c22e408637301c5c /configure.ac
parent6583c1a039a28a41a865b02598e6da9521046325 (diff)
downloadplus-db31c2f832dd4067e4670dd469fe3b696188576b.tar.gz
plus-db31c2f832dd4067e4670dd469fe3b696188576b.tar.bz2
plus-db31c2f832dd4067e4670dd469fe3b696188576b.tar.xz
plus-db31c2f832dd4067e4670dd469fe3b696188576b.zip
Add configure flag for use physfs.
New configure option: --without-physfs For now manaplus cant be compiled without physfs.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d21537aa8..726f46170 100755
--- a/configure.ac
+++ b/configure.ac
@@ -260,10 +260,18 @@ fi
AC_CHECK_LIB([z], [inflate], ,
AC_MSG_ERROR([ *** Unable to find zlib (http://www.gzip.org/zlib/)]))
-AC_CHECK_LIB([physfs], [PHYSFS_init], ,
-AC_MSG_ERROR([ *** Unable to find PhysFS library (http://icculus.org/physfs/)]))
-AC_CHECK_HEADERS([physfs.h], ,
-AC_MSG_ERROR([ *** PhysFS library found but cannot find headers (http://icculus.org/physfs/)]))
+# Option to enable physfs.
+AC_ARG_WITH(physfs,[ --without-physfs don't use physfs ] )
+if test "x$with_physfs" == "xno"; then
+ with_physfs=no
+else
+ with_physfs=yes
+ AC_CHECK_LIB([physfs], [PHYSFS_init], ,
+ AC_MSG_ERROR([ *** Unable to find PhysFS library (http://icculus.org/physfs/)]))
+ AC_CHECK_HEADERS([physfs.h], ,
+ AC_MSG_ERROR([ *** PhysFS library found but cannot find headers (http://icculus.org/physfs/)]))
+fi
+AM_CONDITIONAL(USE_PHYSFS, test x$with_physfs = xyes)
if test -n "$CURL_CONFIG"; then
LIBS="$LIBS `$CURL_CONFIG --libs`"
@@ -604,6 +612,7 @@ if test "$unittests_enabled" == true; then
fi
echo "Build with OpenGL: $with_opengl"
+echo "Build with physfs: $with_physfs"
echo
echo "LIBS: $LIBS"
echo "CPPFLAGS: $CPPFLAGS"