summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4ee915424..f68adfb59 100755
--- a/configure.ac
+++ b/configure.ac
@@ -638,6 +638,22 @@ fi
AC_CHECK_LD_FLAG(-rdynamic, have_rdynamic)
AM_CONDITIONAL(HAVE_RDYNAMIC, test x$have_rdynamic = xyes)
+AC_CHECK_HEADERS([execinfo.h],
+ [
+ AC_SEARCH_LIBS([backtrace],
+ [execinfo],
+ [
+ have_execinfo=yes
+ ],
+ [
+ have_execinfo=no
+ ]
+ )
+ ],
+ []
+)
+AM_CONDITIONAL(HAVE_EXECINFO, test x$have_execinfo = xyes)
+
AC_CONFIG_FILES([
manaplus.spec
Makefile