summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-02-28 21:29:09 +0300
committerAndrei Karas <akaras@inbox.ru>2015-02-28 21:29:09 +0300
commit510d030cbf0cca87e81801b1f484c24e8d4b7940 (patch)
tree3c90786df7b3b98590bdfd3acd958c6901856a8b /src/Makefile.am
parentb3fb42d3225282bc146847488a74536953a2d726 (diff)
downloadmv-510d030cbf0cca87e81801b1f484c24e8d4b7940.tar.gz
mv-510d030cbf0cca87e81801b1f484c24e8d4b7940.tar.bz2
mv-510d030cbf0cca87e81801b1f484c24e8d4b7940.tar.xz
mv-510d030cbf0cca87e81801b1f484c24e8d4b7940.zip
Build markethandler only if eathena enabled.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 72c23b5a1..a5851cea7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -666,7 +666,6 @@ manaplus_SOURCES += gui/widgets/avatarlistbox.cpp \
net/logindata.h \
net/loginhandler.h \
net/mercenaryhandler.h \
- net/markethandler.h \
net/messagehandler.h \
net/messagein.cpp \
net/messagein.h \
@@ -1268,8 +1267,6 @@ manaplus_SOURCES += \
net/tmwa/itemhandler.h \
net/tmwa/loginhandler.cpp \
net/tmwa/loginhandler.h \
- net/tmwa/markethandler.cpp \
- net/tmwa/markethandler.h \
net/tmwa/mercenaryhandler.cpp \
net/tmwa/mercenaryhandler.h \
net/tmwa/messagehandler.cpp \
@@ -1324,7 +1321,9 @@ manaplus_SOURCES += net/tmwa/auctionhandler.cpp \
net/tmwa/homunculushandler.cpp \
net/tmwa/homunculushandler.h \
net/tmwa/mailhandler.cpp \
- net/tmwa/mailhandler.h
+ net/tmwa/mailhandler.h \
+ net/tmwa/markethandler.cpp \
+ net/tmwa/markethandler.h
endif
manaplus_CXXFLAGS += -DEATHENA_SUPPORT
@@ -1357,6 +1356,7 @@ manaplus_SOURCES += gui/windows/bankwindow.cpp \
net/friendshandler.h \
net/homunculushandler.h \
net/mailhandler.h \
+ net/markethandler.h \
net/eathena/adminhandler.cpp \
net/eathena/adminhandler.h \
net/eathena/auctionhandler.cpp \