summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2014-09-05 17:30:36 +0300
committerAndrei Karas <akaras@inbox.ru>2014-09-06 01:18:57 +0300
commit487d3be4cc8761e5697d4fb95d85e9da8dcaa42e (patch)
tree51ad4b1a6e89fd10a5a30a951879862494264c53 /src/Makefile.am
parente4aea077d98d37ddec91c76ca7ad359e321a7661 (diff)
downloadmv-487d3be4cc8761e5697d4fb95d85e9da8dcaa42e.tar.gz
mv-487d3be4cc8761e5697d4fb95d85e9da8dcaa42e.tar.bz2
mv-487d3be4cc8761e5697d4fb95d85e9da8dcaa42e.tar.xz
mv-487d3be4cc8761e5697d4fb95d85e9da8dcaa42e.zip
Add serverfeatures class for check is server support one or another features.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f849e0163..0e640c7b3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -666,6 +666,7 @@ manaplus_SOURCES += gui/widgets/avatarlistbox.cpp \
net/registrationoptions.h \
net/sdltcpnet.cpp \
net/sdltcpnet.h \
+ net/serverfeatures.h \
net/serverinfo.h \
net/skillhandler.h \
net/tradehandler.h \
@@ -1240,6 +1241,8 @@ manaplus_SOURCES += \
net/tmwa/protocol.h \
net/tmwa/questhandler.cpp \
net/tmwa/questhandler.h \
+ net/tmwa/serverfeatures.cpp \
+ net/tmwa/serverfeatures.h \
net/tmwa/skillhandler.cpp \
net/tmwa/skillhandler.h \
net/tmwa/sprite.h \
@@ -1293,6 +1296,8 @@ manaplus_SOURCES += net/eathena/gui/guildtab.cpp \
net/eathena/protocol.h \
net/eathena/questhandler.cpp \
net/eathena/questhandler.h \
+ net/eathena/serverfeatures.cpp \
+ net/eathena/serverfeatures.h \
net/eathena/skillhandler.cpp \
net/eathena/skillhandler.h \
net/eathena/sprite.h \