summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am212
1 files changed, 161 insertions, 51 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e37e007c..cafe46a7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,13 @@
AUTOMAKE_OPTIONS = subdir-objects
bin_PROGRAMS = tmw
-tmw_SOURCES = gui/widgets/dropdown.cpp \
+
+tmw_CXXFLAGS = -DPKG_DATADIR=\""$(pkgdatadir)/"\" \
+ -DLOCALEDIR=\""$(localedir)"\"
+
+tmw_SOURCES = gui/widgets/avatar.cpp \
+ gui/widgets/avatar.h \
+ gui/widgets/dropdown.cpp \
gui/widgets/dropdown.h \
gui/widgets/layout.cpp \
gui/widgets/layout.h \
@@ -25,8 +31,6 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
gui/buysell.h \
gui/char_select.cpp \
gui/char_select.h \
- gui/char_server.cpp \
- gui/char_server.h \
gui/chat.cpp \
gui/chat.h \
gui/chatinput.cpp \
@@ -35,8 +39,6 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
gui/checkbox.h \
gui/confirm_dialog.cpp \
gui/confirm_dialog.h \
- gui/connection.cpp \
- gui/connection.h \
gui/debugwindow.cpp \
gui/debugwindow.h \
gui/emotecontainer.cpp \
@@ -55,8 +57,10 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
gui/gui.h \
gui/help.cpp \
gui/help.h \
- gui/inttextfield.h \
+ gui/icon.cpp \
+ gui/icon.h \
gui/inttextfield.cpp \
+ gui/inttextfield.h \
gui/inventorywindow.cpp \
gui/inventorywindow.h \
gui/itemcontainer.cpp \
@@ -139,24 +143,20 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
gui/shortcutwindow.h \
gui/shortcutcontainer.cpp \
gui/shortcutcontainer.h \
- gui/skill.cpp \
- gui/skill.h \
gui/skin.cpp \
gui/skin.h \
gui/slider.cpp \
gui/slider.h \
gui/speechbubble.cpp \
gui/speechbubble.h \
- gui/status.cpp \
- gui/status.h \
- gui/storagewindow.cpp \
- gui/storagewindow.h \
gui/table.cpp \
gui/table.h \
gui/table_model.cpp \
gui/table_model.h \
gui/textbox.cpp \
gui/textbox.h \
+ gui/textdialog.cpp \
+ gui/textdialog.h \
gui/textfield.cpp \
gui/textfield.h \
gui/textrenderer.h \
@@ -164,52 +164,20 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
gui/trade.h \
gui/truetypefont.cpp \
gui/truetypefont.h \
- gui/updatewindow.h \
gui/updatewindow.cpp \
+ gui/updatewindow.h \
gui/viewport.cpp \
gui/viewport.h \
gui/window.cpp \
gui/window.h \
gui/windowcontainer.cpp \
gui/windowcontainer.h \
- net/beinghandler.h \
- net/beinghandler.cpp \
- net/buysellhandler.h \
- net/buysellhandler.cpp \
- net/charserverhandler.h \
- net/charserverhandler.cpp \
- net/chathandler.h \
- net/chathandler.cpp \
- net/equipmenthandler.h \
- net/equipmenthandler.cpp \
- net/inventoryhandler.h \
- net/inventoryhandler.cpp \
- net/itemhandler.h \
- net/itemhandler.cpp \
- net/loginhandler.h \
- net/loginhandler.cpp \
- net/maploginhandler.cpp \
- net/maploginhandler.h \
net/messagehandler.cpp \
net/messagehandler.h \
net/messagein.cpp \
net/messagein.h \
net/messageout.cpp \
net/messageout.h \
- net/network.cpp \
- net/network.h \
- net/npchandler.cpp \
- net/npchandler.h \
- net/partyhandler.cpp \
- net/partyhandler.h \
- net/playerhandler.cpp \
- net/playerhandler.h \
- net/protocol.cpp \
- net/protocol.h \
- net/skillhandler.cpp \
- net/skillhandler.h \
- net/tradehandler.cpp \
- net/tradehandler.h \
resources/action.cpp \
resources/action.h \
resources/ambientoverlay.cpp \
@@ -257,6 +225,8 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
utils/dtor.h \
utils/fastsqrt.h \
utils/gettext.h \
+ utils/sha256.cpp \
+ utils/sha256.h \
utils/stringutils.cpp \
utils/stringutils.h \
utils/strprintf.cpp \
@@ -272,6 +242,12 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
being.h \
beingmanager.cpp \
beingmanager.h \
+ channel.cpp \
+ channel.h \
+ channelmanager.cpp \
+ channelmanager.h \
+ commandhandler.cpp \
+ commandhandler.h \
configlistener.h \
configuration.cpp \
configuration.h \
@@ -327,8 +303,6 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
particleemitter.cpp \
particleemitter.h \
particleemitterprop.h \
- party.cpp \
- party.h \
player.cpp \
player.h \
player_relations.cpp \
@@ -358,8 +332,144 @@ tmw_SOURCES = gui/widgets/dropdown.cpp \
vector.cpp \
vector.h
+if SERVER_TMWSERV
+tmw_CXXFLAGS += -DTMWSERV_SUPPORT
+tmw_SOURCES += \
+ gui/buddywindow.cpp \
+ gui/buddywindow.h \
+ gui/changeemaildialog.cpp \
+ gui/changeemaildialog.h \
+ gui/changepassworddialog.cpp \
+ gui/changepassworddialog.h \
+ gui/connection.cpp \
+ gui/connection.h \
+ gui/guildlistbox.cpp \
+ gui/guildlistbox.h \
+ gui/guildwindow.cpp \
+ gui/guildwindow.h \
+ gui/magic.cpp \
+ gui/magic.h \
+ gui/npcpostdialog.cpp \
+ gui/npcpostdialog.h \
+ gui/partywindow.cpp \
+ gui/partywindow.h \
+ gui/quitdialog.cpp \
+ gui/quitdialog.h \
+ gui/serverdialog.cpp \
+ gui/serverdialog.h \
+ gui/skilldialog.cpp \
+ gui/skilldialog.h \
+ gui/statuswindow.cpp \
+ gui/statuswindow.h \
+ gui/unregisterdialog.cpp \
+ gui/unregisterdialog.h \
+ net/tmwserv/accountserver/account.cpp \
+ net/tmwserv/accountserver/account.h \
+ net/tmwserv/accountserver/accountserver.cpp \
+ net/tmwserv/accountserver/accountserver.h \
+ net/tmwserv/accountserver/internal.cpp \
+ net/tmwserv/accountserver/internal.h \
+ net/tmwserv/chatserver/chatserver.cpp \
+ net/tmwserv/chatserver/chatserver.h \
+ net/tmwserv/chatserver/guild.cpp \
+ net/tmwserv/chatserver/guild.h \
+ net/tmwserv/chatserver/internal.cpp \
+ net/tmwserv/chatserver/internal.h \
+ net/tmwserv/chatserver/party.cpp \
+ net/tmwserv/chatserver/party.h \
+ net/tmwserv/gameserver/gameserver.cpp \
+ net/tmwserv/gameserver/gameserver.h \
+ net/tmwserv/gameserver/internal.cpp \
+ net/tmwserv/gameserver/internal.h \
+ net/tmwserv/gameserver/player.cpp \
+ net/tmwserv/gameserver/player.h \
+ net/tmwserv/beinghandler.cpp \
+ net/tmwserv/beinghandler.h \
+ net/tmwserv/buysellhandler.cpp \
+ net/tmwserv/buysellhandler.h \
+ net/tmwserv/charserverhandler.cpp \
+ net/tmwserv/charserverhandler.h \
+ net/tmwserv/chathandler.cpp \
+ net/tmwserv/chathandler.h \
+ net/tmwserv/connection.cpp \
+ net/tmwserv/connection.h \
+ net/tmwserv/effecthandler.cpp \
+ net/tmwserv/effecthandler.h \
+ net/tmwserv/guildhandler.cpp \
+ net/tmwserv/guildhandler.h \
+ net/tmwserv/internal.cpp \
+ net/tmwserv/internal.h \
+ net/tmwserv/inventoryhandler.cpp \
+ net/tmwserv/inventoryhandler.h \
+ net/tmwserv/itemhandler.h \
+ net/tmwserv/itemhandler.cpp \
+ net/tmwserv/loginhandler.cpp \
+ net/tmwserv/loginhandler.h \
+ net/tmwserv/logouthandler.cpp \
+ net/tmwserv/logouthandler.h \
+ net/tmwserv/network.cpp \
+ net/tmwserv/network.h \
+ net/tmwserv/npchandler.cpp \
+ net/tmwserv/npchandler.h \
+ net/tmwserv/partyhandler.cpp \
+ net/tmwserv/partyhandler.h \
+ net/tmwserv/playerhandler.cpp \
+ net/tmwserv/playerhandler.h \
+ net/tmwserv/protocol.h \
+ net/tmwserv/tradehandler.cpp \
+ net/tmwserv/tradehandler.h \
+ resources/buddylist.cpp \
+ resources/buddylist.h \
+ guild.cpp \
+ guild.h
+endif
+
+if SERVER_EATHENA
+tmw_CXXFLAGS += -DEATHENA_SUPPORT
+tmw_SOURCES += \
+ gui/char_server.cpp \
+ gui/char_server.h \
+ gui/skill.cpp \
+ gui/skill.h \
+ gui/status.cpp \
+ gui/status.h \
+ gui/storagewindow.cpp \
+ gui/storagewindow.h \
+ net/ea/beinghandler.cpp \
+ net/ea/beinghandler.h \
+ net/ea/buysellhandler.cpp \
+ net/ea/buysellhandler.h \
+ net/ea/charserverhandler.cpp \
+ net/ea/charserverhandler.h \
+ net/ea/chathandler.cpp \
+ net/ea/chathandler.h \
+ net/ea/equipmenthandler.cpp \
+ net/ea/equipmenthandler.h \
+ net/ea/inventoryhandler.cpp \
+ net/ea/inventoryhandler.h \
+ net/ea/itemhandler.cpp \
+ net/ea/itemhandler.h \
+ net/ea/loginhandler.cpp \
+ net/ea/loginhandler.h \
+ net/ea/maploginhandler.cpp \
+ net/ea/maploginhandler.h \
+ net/ea/network.cpp \
+ net/ea/network.h \
+ net/ea/npchandler.cpp \
+ net/ea/npchandler.h \
+ net/ea/partyhandler.cpp \
+ net/ea/partyhandler.h \
+ net/ea/playerhandler.cpp \
+ net/ea/playerhandler.h \
+ net/ea/protocol.cpp \
+ net/ea/protocol.h \
+ net/ea/skillhandler.cpp \
+ net/ea/skillhandler.h \
+ net/ea/tradehandler.cpp \
+ net/ea/tradehandler.h \
+ party.cpp \
+ party.h
+endif
+
# set the include path found by configure
-INCLUDES = \
- $(all_includes) \
- -DPKG_DATADIR=\""$(pkgdatadir)/"\" \
- -DLOCALEDIR=\""$(localedir)"\"
+INCLUDES = $(all_includes)