summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSocapex <philippe_groarke@yahoo.ca>2012-08-13 17:53:52 -0400
committerErik Schilling <ablu.erikschilling@googlemail.com>2012-08-14 17:58:43 +0200
commit35108fc2196b1f0d540d0a3bcea9a0023d1c5cc5 (patch)
tree50c6a195c2c16e5866dbdde6a18b6245502640f6 /src/CMakeLists.txt
parent46a6cee5e42c2be0d47e9048111eacd7ef929768 (diff)
downloadmana-35108fc2196b1f0d540d0a3bcea9a0023d1c5cc5.tar.gz
mana-35108fc2196b1f0d540d0a3bcea9a0023d1c5cc5.tar.bz2
mana-35108fc2196b1f0d540d0a3bcea9a0023d1c5cc5.tar.xz
mana-35108fc2196b1f0d540d0a3bcea9a0023d1c5cc5.zip
Can now build using cmake on OSX
Tested-by: Frost.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 05f45e18..74da785a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -652,7 +652,16 @@ IF (WIN32)
utils/specialfolder.h
mana.rc
)
-ENDIF ()
+ENDIF (WIN32)
+
+IF (APPLE)
+ SET(SRCS
+ ${SRCS}
+ log.mm
+ SDLMain.h
+ SDLMain.m
+ )
+ENDIF (APPLE)
SET (PROGRAMS mana)