summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <bjorn@lindeijer.nl>2024-03-12 14:54:55 +0100
committerThorbjørn Lindeijer <bjorn@lindeijer.nl>2024-03-26 20:53:46 +0000
commiteafb9d28563cfc78250d0e0d6f12992e91156727 (patch)
tree974898928a9faba6b606ce8e44727c5580dd9ca7 /CMakeLists.txt
parent6eca1b485dba7355d827745284ed2f0072f9e370 (diff)
downloadmana-eafb9d28563cfc78250d0e0d6f12992e91156727.tar.gz
mana-eafb9d28563cfc78250d0e0d6f12992e91156727.tar.bz2
mana-eafb9d28563cfc78250d0e0d6f12992e91156727.tar.xz
mana-eafb9d28563cfc78250d0e0d6f12992e91156727.zip
CMake: Added USE_SYSTEM_GUICHAN option
So that one can choose to build with the Guichan submodule also on other systems than macOS.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3365ff83..9bf55225 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,7 @@ FIND_PACKAGE(Gettext)
OPTION(WITH_OPENGL "Enable OpenGL support" ON)
OPTION(ENABLE_NLS "Enable building of tranlations" ON)
OPTION(ENABLE_MANASERV "Enable Manaserv support" ON)
+OPTION(USE_SYSTEM_GUICHAN "Use system Guichan" ON)
IF (WIN32)
SET(PKG_DATADIR ".")
@@ -52,7 +53,7 @@ ENDIF()
# On macOS we need to build Guichan ourselves since it is disabled in Homebrew
# This might also be a good idea for the Windows build
-if(APPLE)
+if(APPLE OR NOT USE_SYSTEM_GUICHAN)
# This policy makes sure that the below options are not ignored by the
# added Guichan CMakeLists.txt
SET(CMAKE_POLICY_DEFAULT_CMP0077 NEW)