summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <bjorn@lindeijer.nl>2024-04-08 13:37:57 +0200
committerThorbjørn Lindeijer <bjorn@lindeijer.nl>2024-04-08 16:29:46 +0200
commit8de87c6f2e5896ab4ff7fa473293a0af26f78285 (patch)
treecd1f85194109f8715b6ad328017c65a138cbf31d /CMakeLists.txt
parent27902c01cc74d5d50378aa31eb6c59730d9287ab (diff)
downloadmana-8de87c6f2e5896ab4ff7fa473293a0af26f78285.tar.gz
mana-8de87c6f2e5896ab4ff7fa473293a0af26f78285.tar.bz2
mana-8de87c6f2e5896ab4ff7fa473293a0af26f78285.tar.xz
mana-8de87c6f2e5896ab4ff7fa473293a0af26f78285.zip
CMake: Exclude Guichan headers and library from install
Otherwise they are included in the NSIS installer, as well. We don't need the Guichan library since we link to it statically.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b13ead11..9da0ca6b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,7 +56,7 @@ if(APPLE OR NOT USE_SYSTEM_GUICHAN)
SET(ENABLE_SDL OFF)
SET(ENABLE_OPENGL OFF)
SET(BUILD_GUICHAN_SHARED OFF)
- ADD_SUBDIRECTORY(libs/guichan)
+ ADD_SUBDIRECTORY(libs/guichan EXCLUDE_FROM_ALL)
endif()
ADD_SUBDIRECTORY(src)